Re: [Evolution] LDAP

On Sat, 2004-04-24 at 06:57 -0700, Lonnie Borntreger wrote:
On Sat, 2004-04-24 at 09:08 +0200, Tony Earnshaw wrote:
fre, 23.04.2004 kl. 00.56 skrev Lonnie Borntreger:

I wasn't able to get authenticated access to my LDAP server until I
switched to 1.5 (.3 is when I switched - I think).  Now I'm running
1.5.7 (CVS as of yesterday)...... let me check........  now it DID allow
me to edit an entry, but when trying to save the changes it said the
addressbook backend for that LDAP addressbook died.  Another window said
something about not being able to update entry "U".

It allows me to try again as soon as I force-shutdown and restart - but
has the same crash.

Evo 1.4.5, Openldap 2.2.10

You might like to do a 'tail -f' on the slapd log at the same time as
you're doing your Evo stuff - it'll more than likely tell you how, what
and why. FWIW I have no trouble in adding or editing records, but I bind
as a privileged user with write ACLs on all the attributes needed.

I bind as the "manager", so I should have no permission problems, and
I'm not concerned with 1.4 issues anymore.

For 1.5 (just updated CVS), when I try to save a change - it now doesn't
have anything crash, but it gives an error that says "other error".

Yeah the "U" was because eab_error_dialog's array of error strings
hadn't been updated with the new contents of the EBookStatus enum, which
was pretty bad.

Are you updating the cn of the entry?  There's been some talk of that
failing (and it does for me too, without some recent changes in my
source tree) with openldap 2.1+.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]