Re: [Evolution] LDAP schema

I saw what I will consider bug in the LDAP setup screen. For example,
when I go to edit my LDAP server on the advance page the ONE is always
selected even if I select Sub and save.

Also, How do I unbind from a server ? I am testing different settings
(for example authentication)  but need to get out of evolution, and
killev in most case, to be able to close my connection to my ldap
server.Also I have experienced few freezes when closing evolution.

What about adding an option to get all records from a LDAP server loaded
when binding if one knows that the address book is fairly small. Will
act more like the contact folder.

If I don't want to use the contact folder in the local folder, how can I
replace it with an LDAP folder or can't I ?



On Thu, 2001-09-13 at 21:17, Chris Toshok wrote:
On Thu, 2001-09-13 at 17:02, Pascal DeMilly wrote:
But still I have some questions. 

Looking superficially at the ldap code it seems to me that if my ldap
server was not supporting evolutionperson objectclass, the
check_schema_support looks for support for inetOrgPerson, Person or
OrganizationPerson. If any of the object class is supported, connection
to this ldap server is established. 

However it did seem to work for me as I was only able to access my ldap
address book when I added support to evolutionperson. As I am new to
LDAP, I am sure that somebody will point quickly to my mistake.

that's strange, you should be able to connect just fine (and even edit
cards if you've authenticated) with a server that doesn't have the
evolutionperson schema loaded, although the fields available for
editting changes with what schemas you have loaded.

Also when opening a card, I don't have access to some fields like phone
numbers, e-mail Changing the fullname and some other evolution specific
fields works fine. I can see the values but the field is grayed out
(disabled). What do I need to do to be able to change a phone number or
e-mail address ? Is it because evolution use a different attribute
(primaryphone) over the standard (?) telephonenumber of te objectclass
person ?

Ahh, this is probably because you only loaded the evolutionperson
schema, and so only the fields defined in that schema are available. 
Not many people have actually tried getting the writable/schema stuff
going, so there hasn't been much talk about it on the lists.  Here's the
include directives from my slapd.conf file:

include         /usr/local/etc/openldap/schema/core.schema
include         /usr/local/etc/openldap/schema/cosine.schema
include         /usr/local/etc/openldap/schema/inetorgperson.schema

I normally don't have the evolutionperson schema loaded, mainly because
I wanted to make sure the writable support worked without it.  But those
3 lines, plus the include of evolutionperson.schema should get all
fields that we can store enabled for you.

Lemme know if you have any other problems.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]