Re: [Evolution] LDAP schema

Thanks for providing some feedback.

Actually I had all the schema you specified loaded. I suspect now a
problem with my server setting, probably with ACL, as I am just starting
with LDAP and I have to admit it is all rather obscure.

my current ACL is set to: access to * by * write. which I thought would
be like saying, anybody can access this database in write mode. (Please
remember that I am testing it and not in production. by that time I
expect to have SSL or TLS and SASL understood and working). But it
doesn't or I should say it almost does as I am able to add new cards
(which I really like), but some fields are still disabled like phone
numbers and e-mail address. Any idea why ?

For those interested I found the evolution schema at:



On Thu, 2001-09-13 at 21:17, Chris Toshok wrote:
On Thu, 2001-09-13 at 17:02, Pascal DeMilly wrote:
But still I have some questions. 

Looking superficially at the ldap code it seems to me that if my ldap
server was not supporting evolutionperson objectclass, the
check_schema_support looks for support for inetOrgPerson, Person or
OrganizationPerson. If any of the object class is supported, connection
to this ldap server is established. 

However it did seem to work for me as I was only able to access my ldap
address book when I added support to evolutionperson. As I am new to
LDAP, I am sure that somebody will point quickly to my mistake.

that's strange, you should be able to connect just fine (and even edit
cards if you've authenticated) with a server that doesn't have the
evolutionperson schema loaded, although the fields available for
editting changes with what schemas you have loaded.

Also when opening a card, I don't have access to some fields like phone
numbers, e-mail Changing the fullname and some other evolution specific
fields works fine. I can see the values but the field is grayed out
(disabled). What do I need to do to be able to change a phone number or
e-mail address ? Is it because evolution use a different attribute
(primaryphone) over the standard (?) telephonenumber of te objectclass
person ?

Ahh, this is probably because you only loaded the evolutionperson
schema, and so only the fields defined in that schema are available. 
Not many people have actually tried getting the writable/schema stuff
going, so there hasn't been much talk about it on the lists.  Here's the
include directives from my slapd.conf file:

include         /usr/local/etc/openldap/schema/core.schema
include         /usr/local/etc/openldap/schema/cosine.schema
include         /usr/local/etc/openldap/schema/inetorgperson.schema

I normally don't have the evolutionperson schema loaded, mainly because
I wanted to make sure the writable support worked without it.  But those
3 lines, plus the include of evolutionperson.schema should get all
fields that we can store enabled for you.

Lemme know if you have any other problems.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]