Re: [Evolution] Composer problems with 0.10

I just started using RedCarpet and broke Evolution trying to get RedCarpet working.

After upgrading a few components via RedCarpet RPMs (now running RH 7.1)
that I had previously compiled, evolution wouldn't start. Turned out I
had extra files floating around. (well, okay - I had two seperate
installs of Evolution now) I removed a series of files, re-ran the
RedCarpet and got Evolution to open, but the composer window wouldn't
work, most-likely a GTKHTML problem. Note I had perhaps 10 manually
compiled libs and programs from my original attempts to get Evolution
working. I wanted to replace all that work with RPMs and start using

Here's what I did:

I removed the RPMS for Evolution, GTKHTML, libunicode and GAL. (even
though all that may not have been necessary, it's what I did).

Then I ran an updatedb and searched through the hard-drive for
extra/old/useless files associated with each of these packages. I
deleted what I was sure about, backed up what I wasn't sure about and
ran updatedb again to double-check.

Then I ran GTKHTML, GAL and libunicode RPMs to satisfy the Red-Carpet
dependancies and re-installed Red-Carpet
(red-carpet-1.0-ximian.10.i386.rpm) with --replacepkgs

Red-Carpet fired up, I subscribed to the Evolution channel and upgraded
GAL, GTKHTML and then clicked Evolution. Red-Carpet picked up several
other old packages, downloaded, upgraded and installed and I was good to

Give it a try and good luck!

Don't forget to back-up you're evolution folder in your home directory -
mine was fine but you never know.

Mike : )

On 14 May 2001 13:54:38 -0700, Phil Schwartz wrote:

A month or so ago I posted that I could not use the message composer w/
Evo 0.10 using the nightly snapshots.  I tried re-installing each
component over the course of a week or so before finally giving up.  I
downloaded the evolution-0.10-ximian.1.i386.rpm using redcarpet today
and unfortunately the problem still exists.  

The problem is:  I click on "Compose" (or reply, or forward), the
composition window appears and I can enter text into the message body
and the message subject fields.  However, I cannot enter anything into
the "to" or "cc" fields which renders the composer completely useless.
These 2 fields appear as a solid grey region with no input areas.

I've scanned the message archives and still cannot find a solution.
I've tried the following:
rm /tmp/orbit-phil
rm /usr/share/oaf/GNOME_Gtkhtml*oafinfo

Re-started evolution and composer, same problem.

I've even tried changing the fonts (as someone had suggested) by
clicking on the composer window's Edit -> Properties option and then
changing the values of the "On Screen - Fixed width" font.  I tried
several, arial, helvetica, courier, but no luck.

So once again, I've reverted back to the 0.9 release because I don't
experience any composer related problems.  I'm not sure what to do
anymore in order to get 0.10 to work.

For the record, I'm running Redhat 7.0 with Gnome 1.4 (just upgraded to
1.4, but the problem existed with the last release as well).  Other rpms
which may be of interest:


I'd really like to use the latest and greate Evo but I'm stuck w/ 0.9
until I can get this problem resolved.

Thanks for any help,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]