Re: [Evolution] 'Cannot initialize Evolution shell' error

Thanks for the help. I did force some dependencies as I could not remove the components through red-carpet because of those dependencies so I removed everything and then ran red-carpet to reinstall.

I did find sone .oafinfo files in /usr/local/share and I deleted the whole oaf directory there as well as deleteing the .oafinfo files in /usr/share/oaf. I still get the same error when I run as my normal user and as root. Here is the gdb trace when running Evolution as root:

"Starting program: /usr/bin/evolution

GnomeUI-WARNING **: While connecting to session manager:
Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed.

GLib-CRITICAL **: file ghash.c: line 138 (g_hash_table_lookup): assertion `hash_table != NULL' failed.

GLib-CRITICAL **: file ghash.c: line 138 (g_hash_table_lookup): assertion `hash_table != NULL' failed.

Program exited with code 01"

Does this help?

Ben Ricker
System Administrator

Ettore Perazzoli wrote:

I too have get the Evolution shell error and I even posted a gdb traceback, but no one responded. I have made *4* attempts to get an answer and no one has responded except those who said "I have the same problem and no one responded".

  OK, the reason for this is simply that OAF doesn't make it easy for us
to figure out what is wrong.

  If the shell reports that it cannot be initialized, it simply means
that OAF couldn't register it as a component.  Unfortunately, OAF
doesn't return a helpful error code, so we cannot pop up a more useful
error message nor easily figure out what is wrong with your machine.

  The only thing I am sure about is that this should never ever happen
with the Ximian packages.  It is caused by either a nasty OAF bug that
we don't know about, or simply an installation problem.

  Anyway, try checking these things:

    * Make sure that GNOME_Evolution_Shell.oaf and the other
      GNOME_Evolution*.oaf files are installed in $prefix/share/oaf.
      (If you install from RPMs, that would be /usr/share/oaf.)  These
      files must be readable by yourself.

    * Make sure there are no old evolution-related .oafinfo files that
      are not installed by the packages in $prefix/share/oaf nor any
      other of the prefixes listed in eitehr GNOME_PATH or

  My feeling is that you installed something by hand or forced some
dependencies (or maybe mixed packages), and that your system is now not
100% clean.

  I hope this helps, and sorry for your troubles.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]