Re: [Evolution] another cvs compile error

On 12 Jul 2001 23:18:09 +0200, Brendon Leese wrote:
On Thursday 12 July 2001 19:29, you wrote:
On 12 Jul 2001 19:02:50 +0200, Brendon Leese wrote:
After I finally found and compiled all the necessary libraries needed to
compile evolution I've run into these error messages:

e-categories-master-list-wombat.c: In function `ecmlw_load':
e-categories-master-list-wombat.c:76: too many arguments to function
e-categories-master-list-wombat.c: In function `ecmlw_save':
e-categories-master-list-wombat.c:114: warning: implicit declaration of
function `e_categories_master_list_nth_icon'
e-categories-master-list-wombat.c:114: warning: assignment makes pointer
from integer without a cast
e-categories-master-list-wombat.c:115: warning: implicit declaration of
function `e_categories_master_list_nth_color'
e-categories-master-list-wombat.c:115: warning: assignment makes pointer
from integer without a cast
make[3]: *** [e-categories-master-list-wombat.lo] Error 1
make[3]: Leaving directory `/home/wleese/cvs/evolution/e-util'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/wleese/cvs/evolution/e-util'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/wleese/cvs/evolution'
make: *** [all-recursive-am] Error 2
after doing a make. No additional arguments were given at the command
line, just: ./ && make

yes, it seems you need to update your gal version, since all those missing
functions were recently added to gal.

I pulled gal from cvs, compiled it and install it into /usr/local/. Yet when 
trying to compile Evolution I still receive the same error message. 

This is what I've tried:

./ --with-db3-libs=/home/bleese/db-3.1.17/build_unix/ 
--with-gal-includes=/usr/local/include/gal/ --with-gal-libs=/usr/local/lib/ 

you still don't have the latest gal. Maybe it's an anoncvs syncing problem, or
maybe you've got an older version already installed (maybe in /usr ?)
which is the one evolution is using when compiling. To see if you've got
the latest gal, check the file gal/widgets/e-categories-master-list.h
and look in there for 'nth_icon'. If it's there, it's the latest, if
not, you must upgrade.

Rodrigo Moya <rodrigo gnome-db org> - <rodrigo ximian com> -

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]