Re: [Evolution] undefined references in address-conduit-control-applet

On 24 Feb 2001 11:48:20 -0500, Tony Rein wrote:
On Saturday 24 February 2001 07:35, JP Rosevear wrote:
On 23 Feb 2001 20:01:44 -0500, Tony Rein wrote:
I've been trying the last couple of days (Thursday and Friday) to compile
Evolution from cvs source. It keeps failing with the following errors:

address-conduit-control-applet.o: In function `doTrySettings':
applet. c:89: undefined reference to

These symbols come from gnome-pilot.  Check the README for more
information on compiling pilot support.

Thanks for the reply. However, I do have gnome-pilot installed, and I'm still 
doing something wrong. I've tried both with the RPMS from Ximian's ftp site, 
and with gnome-pilot built from cvs, and I still get the above errors. When I 
built gnome-pilot from cvs, I passed the script the parameters:
--prefix=/usr --sysconfdir=/etc --with-pisock=/usr
The above directories are what the rest of my gnome setup is using.
When I build Evolution from cvs, I pass the same parameters, in 
addition to "--enable-pilot-conduits=yes"

Is gnome-pilot supposed to "register" itself somehow with gnome? When I type 
"gnome-config --modversion gnome-pilot" it tells me "no such library." I have 
verified that "ls /usr/lib/*pilot*.*" gives me:

Try gnome-config --modversion gpilot.  Does that give any output?  Also,
for compiling from CVS you need the gob module - is it installed?


JP Rosevear                             jpr ximian com
Ximian Inc.                   

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]