[Evolution-hackers] Questions about evolution-data-server-3.3.4 source code compile

Hi, all

After download evolution-data-server-3.3.4-1.1.src.rpm & install it, I tried to compile it:
Based existed Makefile.am & configure.ac, I run the command:
	aclocal (aclocal -I m4)
Have Installed some packages during compile.

And my problems during compile are
1. after automake, no Makefile.in created, and without errors during automake, below is tail info of automake
	tests/libecal/Makefile.am:5:   its definition is in aclocal's search path.
	tests/libecal/client/Makefile.am:1: Libtool library used but `LIBTOOL' is undefined
	tests/libecal/client/Makefile.am:1:   The usual way to define `LIBTOOL' is to add `AC_PROG_LIBTOOL'
	tests/libecal/client/Makefile.am:1:   to `configure.ac' and run `aclocal' and `autoconf' again.
	tests/libecal/client/Makefile.am:1:   If `AC_PROG_LIBTOOL' is in `configure.ac', make sure
	tests/libecal/client/Makefile.am:1:   its definition is in aclocal's search path.
	[cici@localhost evolution-data-server-3.3.4]$ ls

anyone have met this problem? How to fix it?

2. Is above compile method correct? And do we have auto script or other tools to auto compile?

Besides, I have compiled evolution-data-server-2.32.3 source code successfully, and haven't met this error.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]