Re: Cups Printers not listed in print dialog

В Втр, 26/09/2006 в 15:11 +1000, Daniel Kasak пишет:
> I have a very strange problem. On a new system I'm building, Evince 
> doesn't see any cups printers. If I open firefox to all my 
> network printers are shown. If I open gedit and select File ==> Print, 
> all the cups printers are shown. But Evince doesn't see them. Instead, 
> it gives me the options:
> - Print to File
> - Print to LPR
> I've rebuilt libgnomeprint and libgnomeprintui, as well as evince. I've 
> tried evince-0.6.0 and 0.5.5. I'm using Gentoo, and have the cups use 
> flag enabled ( and everything else - including gnome apps such as gedit, 
> as above - can see cups printers ). I'm starting my session with:
> dbus-launch startx
> and nothing complains about dbus or cups or anything - including evince. 
> I have also tried starting X without the dbus-launch bit.
> I've posted to the Gentoo forums:
> and no-one has given any advice, but one other user posted that he has 
> the same problem.
> Any ideas?

Since 0.5.5 evince switched to gtk2 printing support instead of
libgnomeprint. I think it's either gtk2 bug and upgrade will help or you
are missing some gtk modules. What is listed
in /usr/lib/gtk-2.0/2.10.0/printerbackends?

In my case there is

Attachment: signature.asc
Description: =?koi8-r?Q?=FC=D4=C1?= =?koi8-r?Q?_=DE=C1=D3=D4=D8?= =?koi8-r?Q?_=D3=CF=CF=C2=DD=C5=CE=C9=D1?= =?koi8-r?Q?_=D0=CF=C4=D0=C9=D3=C1=CE=C1?= =?koi8-r?Q?_=C3=C9=C6=D2=CF=D7=CF=CA?= =?koi8-r?Q?_=D0=CF=C4=D0=C9=D3=D8=C0?=

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]