Re: [Ekiga-list] No Echo Test response: STUN Problem with Thomson ST585 V6 ADSL router

Le vendredi 19 décembre 2008 à 22:54 +0000, Terry Barnaby a écrit :
> Hi,
> I have been trying to get Ekiga working on a Fedora 8 based system.
> I am using Ekiga 3.0.1 build from a Fedora 10 source RPM.
> This is being used at home through a ST585 router in NAT configuration.
> When ever I tried to run Ekiga I would get the error message in a dialog
> window:
> "Ekiga did not manage to configure your network settings automatically. You can
> still use it, but you need to configure your network settings manually.
> Please see for
> instructions"
> After this the echo test would fail in the receiving direction. I tried to
> enable port forwarding on my ST585 router to no avail.
> Strangely it was working at work were we use the same ST585 router, but without
> NAT enabled (A Linux box does the firewall).
> After a lot of playing around I used gconf-editor to clear the "stun_server"
> entry for Ekiga. This cured the problem.
> What is strange is that Ekiga now also works without the port forwarding
> enabled in the router ...
> It appears that the ST585 is doing something special when it sees SIP protocol
> requests and forwarding the ports automatically, but the use of the STUN system
> messes this up.
> If this is the case, It would be useful to be able to disable STUN support in
> the standard user preferences dialogs of the Ekiga app and to note this in the
> error dialog window. Also I guess it may be possible to fix the STUN support if
> there is an issue here ...

It is one of the things I want to work on for 3.20 : detect if STUN is
required or if the router supports SIP.
 _     Damien Sandras
//\    Ekiga Softphone :
v_/_   Be IP           :
       FOSDEM          :
       SIP Phone       : sip:dsandras ekiga net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]