Re: [Ekiga-devel-list] Opal 3.6.6 build problem

László Monda a écrit :
> Apart from fixing the version dependency issue of ptlib in the
> configure script, it should be reported to Ubuntu to upgrade from
> Ekiga 3.2.0 to Ekiga 3.2.6 in Jaunty because the former was incredibly
> unstable on my machine and I can see in the changelog the numerous
> stability fixes that have been made between the two versions.

Well, quite frankly, Ubuntu do not do (will) such things. atm I'm trying
to get 3.2.6 in Karmic and I have very few hopes; see

For now, I've packages of 3.2.6 for Jaunty and Karmic here:

> The question is whether they're willing to make the upgrade in the
> lifetime of Jaunty.  3.2.0 is pretty much useless due to stability
> issues based on my experience.
> On Tue, Sep 29, 2009 at 11:00 AM, Eugen Dedu
> <Eugen Dedu pu-pm univ-fcomte fr> wrote:
>> László Monda wrote:
>>> On Sun, Sep 27, 2009 at 11:47 PM, Eugen Dedu
>>> <Eugen Dedu pu-pm univ-fcomte fr> wrote:
>>>> László Monda wrote:
>>>>> Hi List,
>>>>> I've just hit the wall with Opal:
>>>>> laci whisper:~/download/opal-3.6.6$ make
>>>>> [CC] src/opal/manager.cxx
>>>>> In file included from /home/laci/download/opal-3.6.6/include/opal/mediafmt.h:49,
>>>>>                  from
>>>>> /home/laci/download/opal-3.6.6/include/opal/connection.h:44,
>>>>>                  from /home/laci/download/opal-3.6.6/include/opal/call.h:41,
>>>>>                  from /home/laci/download/opal-3.6.6/include/opal/manager.h:41,
>>>>>                  from /home/laci/download/opal-3.6.6/src/opal/manager.cxx:40:
>>>>> /home/laci/download/opal-3.6.6/include/rtp/rtp.h:870: error:
>>>>> ‘PSafePtrMultiThreaded’ was not declared in this scope
>>>>> /home/laci/download/opal-3.6.6/include/rtp/rtp.h:870: error: wrong
>>>>> number of template arguments (2, should be 1)
>>>>> /usr/include/ptlib/safecoll.h:584: error: provided for ‘template<class
>>>>> T> class PSafePtr’
>>>>> make: *** [/home/laci/download/opal-3.6.6/lib_linux_x86/obj/manager.o] Error 1
>>>> Hi,
>>>> Here manager.cxx compiles very well.  You should:
>>>> - provide information about configuration parameters you have used
>>>> - the ptlib version you use
>>> It works now.  I used the libpt2.6.1-dev package of Ubuntu Jaunty and
>>> that's why the build failed.  When using ptlib-2.6.5.tar.gz that is
>>> provided in the Ekiga download page it worked like a charm.
>>> Wouldn't it be useful to notify the folks to use the provided tarballs
>>> instead of distribution-specific dev packages?  It could be mentioned
>>> in a little text next to the tarballs.
>> The problem is not where the tarball comes from.  The problem is the
>> version.  I will inform the person invoved...
>> --
>> Eugen
>> _______________________________________________
>> Ekiga-devel-list mailing list
>> Ekiga-devel-list gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]