Re: [Ekiga-devel-list] Opal 3.6.6 build problem

László Monda wrote:
> On Sun, Sep 27, 2009 at 11:47 PM, Eugen Dedu
> <Eugen Dedu pu-pm univ-fcomte fr> wrote:
>> László Monda wrote:
>>> Hi List,
>>> I've just hit the wall with Opal:
>>> laci whisper:~/download/opal-3.6.6$ make
>>> [CC] src/opal/manager.cxx
>>> In file included from /home/laci/download/opal-3.6.6/include/opal/mediafmt.h:49,
>>>                  from
>>> /home/laci/download/opal-3.6.6/include/opal/connection.h:44,
>>>                  from /home/laci/download/opal-3.6.6/include/opal/call.h:41,
>>>                  from /home/laci/download/opal-3.6.6/include/opal/manager.h:41,
>>>                  from /home/laci/download/opal-3.6.6/src/opal/manager.cxx:40:
>>> /home/laci/download/opal-3.6.6/include/rtp/rtp.h:870: error:
>>> ‘PSafePtrMultiThreaded’ was not declared in this scope
>>> /home/laci/download/opal-3.6.6/include/rtp/rtp.h:870: error: wrong
>>> number of template arguments (2, should be 1)
>>> /usr/include/ptlib/safecoll.h:584: error: provided for ‘template<class
>>> T> class PSafePtr’
>>> make: *** [/home/laci/download/opal-3.6.6/lib_linux_x86/obj/manager.o] Error 1
>> Hi,
>> Here manager.cxx compiles very well.  You should:
>> - provide information about configuration parameters you have used
>> - the ptlib version you use
> It works now.  I used the libpt2.6.1-dev package of Ubuntu Jaunty and
> that's why the build failed.  When using ptlib-2.6.5.tar.gz that is
> provided in the Ekiga download page it worked like a charm.
> Wouldn't it be useful to notify the folks to use the provided tarballs
> instead of distribution-specific dev packages?  It could be mentioned
> in a little text next to the tarballs.

The problem is not where the tarball comes from.  The problem is the
version.  I will inform the person invoved...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]