Re: Debugging dia?

Quoth Hans Breuer:
Am 30.05.2008 09:27, Don Blaheta schrieb:
I can't figure out how to run dia from within gdb.  Based on my reading
of I tried

  setenv DEBUGGER gdb

DEBUGGER=gdb app/
works for me.

What I posted is essentially the equivalent of that for csh-based shells
(I use tcsh) but just in case, I tried the other formulation in bash,
with the same results.

but that gave me the message

  libtool relink stage necessary before debugging is possible.
  please run ./app/ once without a debugger.

I have not tested if it works without giving --enable-debug=yes to 
configure but I guess it would

I had already tried that (sorry, forgot to mention it), and it gave me
the results I mentioned.  This time, I ran 'make clean', then reran
'./configure --enable-debug=yes', then make.  Still getting the above
message when I try to run in a debugger.

Running it "once" without a debugger doesn't help, of course (that's how
I've been running it up until now), and I'm not sure how to trigger the
necessary relink.  I'm not finding rules for making "lt-dia" in any of
the places I'm looking.

If you look into app/ (generated by app/Makefile) you should find 
it ;)

Find how to make it?  That's certainly how I found out it was supposed
to exist, but doesn't really give any indication of how to
build it.

-=-Don Blaheta-=-=-blahedo blahedo org-=-=-=-<>-=-
Latest survey shows that 3 out of 4 people make up 75% of the world's

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]