Re: Problems with dia-0.91-pre1

å 2003-02-05 ä ç 22:59ï Lars Clausen åéï
On 05 Feb 2003, Zhang Linbo wrote:
å 2003-02-04 ä ç 04:24ï Lars Clausen åéï
On Mon, 3 Feb 2003, Zhang Lin-bo wrote:
I tested dia-0.91-pre1 on my system and I found out the following

1. cmdline arguments are not processed.

Do you have libpopt(-devel) installed?

I have popt-1.7-1.06distributed with rh8.0. It's a combination
of the libpopt and libpopt-devel packages, I think.

I fixed a problem with Gnome-enabled builds and opening diagrams from the
command line yesterday.  Please check if this cures your bug in the next
prerelease (or by compiling CVS).

Yes the cmdline arguments now work well. Here's a list of other minor
problems or suggestions (with dia-CVS-20030205-0824):

a) The plug-ins/pixbuf/ is missing.

b) The dependency libxml(-devel) >= 2.3.9 in dia.spec causes problem on
RH8.0 (the library is provided in the packages libxml2(-devel)).

c) The font attributes is now correctly handled. A feature request:
map font names which have changed to corresponding new ones.

d) 'dia --help' works but 'dia -h' doesn't.

e) convert messages to the user's (some messages are in raw utf-8

f) Is it better to put dia.1.gz in /usr/share/man/man1 instead of

The only feature missing for me now is the input method for Simplified
Chinese, currently I use text copy/paste for inputting Chinese



Lars Clausen (| HÃrdgrim of Numenor
"I do not agree with a word that you say, but I   |----------------------------
will defend to the death your right to say it."   | Where are we going, and
    --Evelyn Beatrice Hall paraphrasing Voltaire  | what's with the handbasket?
Dia-list mailing list
Dia-list gnome org
FAQ at
Main page at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]