Re: gudev from my grandpa


On Thu, Aug 25, 2011 at 7:36 AM, Olav Vitters <olav vitters nl> wrote:
> On Thu, Aug 25, 2011 at 01:34:36PM +0300, Zeeshan Ali (Khattak) wrote:
>>   Ah, sorry! My dyslexia kicks-in sometimes. However, thats still
>> pretty old so my question remains.
> We upgrade if needed. Keeping the requirements low makes it easier to
> use stuff from your distribution.
> Is a newer version needed?

In this particular case, libgudev version 163 has a bug fix so the
library can be used safely in multi-threaded applications. This is the
commit in question;a=commitdiff;h=cbdf255e255adc0f30b40be296fbbf2f3cd2be80

In the future, for gudev, please either track HEAD or rely on the
distro to provide a sufficiently new version (ideally the latter) -
this business of locking onto old versions is just very bad practice
and confusing for everyone and it's pretty annoying to see that bug
fixes made almost a year ago isn't being used. Who knows what other
kinds of bugs this has caused...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]