Re: bumping clutter's external dependencies for 2.30

On Thu, 2010-03-18 at 23:20 -0500, Jason D. Clinton wrote:
> On Thu, Mar 18, 2010 at 6:51 PM, Jason D. Clinton
> <me jasonclinton com> wrote:
>         If there's some reason to bump that I don't know about, then
>         we can, of course, but everything will need to be checked and
>         I don't have time for that until this weekend.
> I briefly compiled clutter-1.2 HEAD and clutter-gtk-0.10 HEAD and
> tried everything. Aisleriot has some new rendering artifacts but other
> than that, I'm cautiously optimistic that it would be safe to bump the
> dependency. It appears to be needed anyway since older
> clutter-gtk-0.10 doesn't compile against GTK+ 2.19.ish. (Two cherry
> picks were enough to fix it.)

yep, the main reason for asking to bump from clutter-gtk 0.10.2 to
0.10.4 is because of the fixes that went into making clutter-gtk compile
against the version of gtk+ that's going to ship with Gnome 2.30. this
brings clutter-1.2 along because of the changes in dealing with input
device state which affect embedding a stage into another toolkit like

the proposed bumps for 2.30 are:

  clutter >= 1.2.0
  clutter-gtk >= 0.10.4

the artifacts might be due to the new sub-region update code, or if
aisleriot is reading back texture data from cogl; we have two fixes
already in the pipeline for that that will be backported to clutter-1.2



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]