Re: Call to maintainers: GNOME 2.31 to ship GTK 2.90

Le 12/06/10 14:49, Bastien Nocera a écrit :
On Fri, 2010-06-11 at 18:36 +0200, Xavier Claessens wrote:
Le 10/06/10 13:27, Richard Hughes a écrit :
On 10 June 2010 12:24, Andre Klapper<ak-47 gmx net>   wrote:
This requires module maintainers to port their modules now (if you don't
want an angry release-team mob soon in front of your house).

So, should we be requesting gtk3>= 2.90 in now? At least
for Fedora rawhide the lack of gtk-engines makes all the gtk3-using
application look fugly.

To make Empathy build with gtk3 we need:

   - libcanberra-gtk-3
   - libchamplain-gtk-3
   - libclutter-gtk-3
   - libunique-3 (or drop gtk2 compatibility and use GtkApplication)

Emmanuele could do a release.

   - libwebkit-3

Once they are all released and parallel installable (we would like to
not lose gtk2 compatibility), we are ready to make the move :-)

Why is losing GTK2 compatibility a problem? It shouldn't matter. You
could create a gnome-2-32 branch and make changes there if you wanted.

Ubuntu told me that Maverick (the next ubuntu release) is not going to ship GTK3, and if we can't build Empathy with GTK2 then they'll just keep Empathy 2.30.x... tbh I think that's a bad decision from Ubuntu, but it would be really sad to not ship the latest empathy...

But I guess if the whole GNOME 2.32 depends on GTK3 then they'll change their mind.

Xavier Claessens.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]