Re: [Fwd: Post-It Notes]

On Fri, Nov 29, 2002 at 05:03:37PM -0800, Loban Amaan Rahman wrote: 
> You can download the package to try out from:
> Feedback is welcome!

I think it's a good feature we should have. Here are some issues I

 - the .server file ends up with "/usr/libexec/postit_applet" instead
   of prefix/libexec - I don't understand what causes that
   (you could just drop the full path off of the location= field 
 - the applet doesn't shrink for small panels
 - moving the post-it causes it to jump oddly when you first 
   click. Change window_move_cb as follows and it should work:
       if (event->button == 1) {
                                     event->button, event->x,
                                     event->y, event->time);
 - I think the postit should have a little "X" in the top right for
   closing it. 
 - another option is to set type UTILITY as 
   in gtk_window_set_type_hint() and allow the window manager
   to decorate the postit. This will also kill off 
   the option to minimize/maximize the note.
 - should probably gtk_window_set_skip_taskbar_hint() 
   and gtk_window_set_skip_pager_hint()
 - both of the above are in GTK 2.1.x only I think
 - if I type a long postit, then delete all the text, 
   the postit doesn't shrink. Suggest making the 
   window not resizable with gtk_window_set_resizable()
   then connect_after to size_request on the GtkTextView
   and if requisition->width/requisition->height are
   less than 100 set them to 100. (There must be an 
   easier way but I'm blanking, maybe that hack will work)
 - I would say "delete note" not "destroy note" in the menu
 - the "save all" menu item doesn't make sense to me, they 
   should save automatically right? just have an idle 
   handler or timeout that saves everything every 
   time something changes.
 - if "hide all" minimizes the notes (instead of completely 
   withdrawing them with gtk_widget_hide()) I would say 
   it should be called "minimize all." But I don't think 
   minimize makes sense if the notes are skip_taskbar.
   So I would gtk_widget_hide() instead of iconifying the notes.
 - "Post-It" is a registered trademark, we have to call it 
   "sticky notes" or something like that.
 - in postit_load() it wouldn't hurt to be more robust 
   against a broken XML file (e.g. xmlGetProp() returning null)

It looks nice, I hope we can add this applet.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]