Post-It Notes

Merry Christmas everyone!

I've implemented Havoc's suggestions and kept Kevin's advice in mind.
There's some additional changes too (check the ChangeLog if interested).
Here's what I've got now:

> is my advice to get it included in gnome-applets. I think an applet 
> like this should be very simple. Looking at goats, it seems to me to 
> be an overkill

I'll remember that.

>  - the .server file ends up with "/usr/libexec/postit_applet" instead
>    of prefix/libexec - I don't understand what causes that
>    (you could just drop the full path off of the location= field 
>    perhaps)


>  - the applet doesn't shrink for small panels

Fixed. Also expands for large panels.

>  - moving the post-it causes it to jump oddly when you first 
>    click. Change window_move_cb as follows and it should work:
>        if (event->button == 1) {
>           gtk_window_begin_move_drag(GTK_WINDOW(postit->window),
>                                      event->button, event->x,
>                                      event->y, event->time);
>        }

Fixed. It should be event->x_root and event->y_root though.

>  - I think the postit should have a little "X" in the top right for
>    closing it. 

Done. There's also a little icon for resizing.

>  - should probably gtk_window_set_skip_taskbar_hint() 
>    and gtk_window_set_skip_pager_hint()
>  - both of the above are in GTK 2.1.x only I think

Done using the closest Gtk 2.0 equivalent (by setting window type hint
to TOOLBAR). I've got the Gtk 2.2 code in there, but "#if 0"'ed away for
now. (I haven't gotten Gtk 2.2 installed).

>  - if I type a long postit, then delete all the text, 
>    the postit doesn't shrink. Suggest making the 
>    window not resizable with gtk_window_set_resizable()
>    then connect_after to size_request on the GtkTextView
>    and if requisition->width/requisition->height are
>    less than 100 set them to 100. (There must be an 
>    easier way but I'm blanking, maybe that hack will work)

Done. I have no idea how to implement your suggestion, so I solved this
by making each postit user-resizable.

>  - I would say "delete note" not "destroy note" in the menu

Done. Hmm, I'd rather choose one of these pairs: New/Delete,
Create/Destroy, Add/Remove. Which is best? All sound better than
Create/Delete. I've currently put New/Delete.

>  - the "save all" menu item doesn't make sense to me, they 
>    should save automatically right? just have an idle 
>    handler or timeout that saves everything every 
>    time something changes.

Done. Auto-saves every 5 mins and also when applet exits.

>  - if "hide all" minimizes the notes (instead of completely 
>    withdrawing them with gtk_widget_hide()) I would say 
>    it should be called "minimize all." But I don't think 
>    minimize makes sense if the notes are skip_taskbar.
>    So I would gtk_widget_hide() instead of iconifying the notes.


>  - "Post-It" is a registered trademark, we have to call it 
>    "sticky notes" or something like that. 

Fixed. Renamed to "Sticky Notes"

>  - in postit_load() it wouldn't hurt to be more robust 
>    against a broken XML file (e.g. xmlGetProp() returning null)



|   Loban Amaan Rahman  <-- anagram of -->  Aha! An Abnormal Man!   |
| loban earthling net, loban caltech edu, |

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]