Fixing "fixme:foo" property names, attention other UI devs

 I will be doing some cleanup of beagle property names in the next
few weeks. You might have noticed that most property names currently
used in beagle are of type "fixme:name". The "fixme" part deserves to
be fixed and I feel this is a good time with cleanup happening all
over beagle code.
 What I plan to do is to replace the "fixme" by a proper namespace e.g.
"image" for general image properties
"jpeg" for jpeg specific properties
"contact" for contact specific properties
"package" for package specific properties
I will also add the rough guidelines somewhere on the wiki. Note that,
filter writers are _free_ to choose whatever property names they wish.
So, the guidelines are not strict rules but following them will make
it easier to integrate results in the different UI clients. It will
also allow us to use meaningful words in property queries.

I will change the names in the filter/backend code and accordingly
change it in beagle-search code. I will also change it in kerry (and
yabi, kbeaglebar code as well). But I do not have access to the code
of any other client like deskbar, peagle etc. so I will not be able to
change the names in them. So, those clients could remain broken for a
while. If you are using them, please refrain from using svn trunk for
the time being.

If anyone has any suggestions on deciding the correct namespaces for
property names, feel free to discuss. I want to get it correct and I
looking forward to suggestions.

- dBera

Debajyoti Bera @
beagle / KDE fan
Mandriva / Inspiron-1100 user

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]