problems in CVS

I tried the CVS head today - since more-better-lucene-branch has been
merged. A few things I noted while I was trying to do keyword based
1) the webservices code is broken - wont compile (number of arguments
to DoQuery(...) has increased)
2) The query interface is quite clean now with separate
querypart_text, querypart_property etc. Just that
beagle-query-part-property.c:beagle_query_part_property_to_xml also
needs to add the the property_type of the querypart
3) For some reason the values for property fields are not tokenized
i.e. if I am doing a query on the artist field, I succeed with
"Richard Wagner" but not with richard  (or wagner) (verified the index
fields and values using luke). I dont think this is the correct
behaviour but I am not sure.
4) Incidentally I now have two copies of the CVS. One a few days after
and one a few days before more-better-lucene-branch. Also I am running
without inotify.
  The one before the branch runs fine while the one after the branch
keeps looping in a directory (somewhat like ). I have stored the
log files and index separately in case any of the developers need them
for debugging.

I am sure these problems are being worked upon. Just wanted to mention
them in case they are missed.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]