Re: F-Spot dataprovider

Hey John.

> On Jan 26, 2008 11:21 AM, Trond Andersen <trond andersen gmail com> wrote:
> > I've tried the F-Spot dataprovider to transfer pictures to my Picasa
> > Webalbum. I've configured the F-Spot provider to synchronize a
> > specific tag, but when running it from the console it returns:
> >
> > Delta: Got 0 items.
> >
> > It also gives me an error message stating the following:
> >
> > [DeltaProvider       ][INFO   ] Delta: Source
> > (FspotSource-trond xxxxxx) does not implement get_changes().
> > Proxying... (
> >
> > Does this relate to the fact that it doesn't seem to find any items
> > that should be synchronized?
> Hi Trond, thanks for your mail,
> Please ensure that you are running both Conduit and FSpot from SVN.
> Also ensure that you add the "FSpot DBus dataprovider" (FSpot must be
> running for it to be visible in the Conduit GUI). We are going to be
> depreciating the old FSpot interface soon, and only using the DBus one
> as it allows twoway sync.
I was running F-Spot while this happened. The DBus name in the other
F-Spot provider should probably be named something else. A regular
user shouldn't know about DBus.

I tried the DBus provider for F-Spot, but when running it I got the
following error-message:

org.freedesktop.DBus.Error.UnknownMethod: Method "GetTagNames" with
signature "" on interface "org.gnome.FSpot.TagRemoteControl" doesn't

The user interface to configure the dataprovider didn't manage to show
any tags. The F-Spot version is 0.40 and Conduit is 0.3.6 built on
Ubuntu 7.10.

Would you like a Bug report?

Best regards,
Trond Andersen

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]