Re: Latest changes, and RHEL5

> Hello all,
> After GNOME migration to Git I updated both build master and build
> slave running on, in doing so I forgot it had a local
> change to enable running coverage reports; Iago (I think) enabled it
> with a local commit but today I tried to pull new changes and
> something went wrong somewhere, as I couldn't get out of the Git mess
> (I created(?) I removed everything and started anew.

IIRC, I added some property in the step that was used in jhbuild to check
if the slave should actually execute that command or not. Pretty much what
you implemented below:

> By a pure coincidence I worked yesterday on jhbuild buildbot support
> to be able to disable/enable steps of build slaves, from the slave XML
> description.  Current options are run_checks, run_coverage_report and
> run_clean_afterwards, so I updated RHEL5.xml to look like this:
>   <botslave>
>     <config>
>       <max_builds>2</max_builds>
>       <run_coverage_report>yes</run_coverage_report>
>       <run_clean_afterwards>yes</run_clean_afterwards>
>     </config>
>     [...]
> I restarted the server, it went fine, and the slave, and it went up,
> and all was well, *BUT* the slave now gets orders, such as
>  2009-05-06 10:34:34+0000 [Broker,client] <SlaveBuilder
>    'hamster-applet-RHEL5' at 15608432>.startBuild
> and doesn't act on them, making it quite useless.
> I didn't find anything up to now, so I welcome any new insight, Iago ?

Not sure what could be happening, but API and I can take a look at it


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]