Re: [RFC] Balsa coding style

Hi Albrecht:

On Mar 24, 2016, at 11:29 AM, Albrecht Dreß wrote:
Hi Peter:

Am 13.03.16 00:22 schrieb(en) Peter Bloomfield:
I tried:

[me home balsa]$ find . -name '*.[ch]' -exec indent -kr -i4 -l132 -lc132 -ts4 -psl '{}' ';'
indent: ./libbalsa/libbalsa-gpgme-cb.h:55: Error:Stmt nesting error.
indent: ./libbalsa/imap/imap-handle.c:1843: Warning:old style assignment ambiguity in "=-". Assuming "= -"
indent: ./src/main-window.c:5112: Error:Unexpected end of file

Hmmm, that's strange. I also tried the command above on the current git tree as of today, but got *no* errors. I use GNU indent 2.2.11, running on Ubuntu 14.04 LTS. Which version do you use?

I fixed those with commits 3b153c269452d101d636517eb2aaf7a80f257b17, d974eff00abf87f12a88bb777a2926e6f76f0786, and 7649b8da19e2a198f1beeb32938002433107dfce, respectively. I also now see no errors!


Attachment: pgpwNMy5G8o84.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]