RE: Cannot Read Mailbox

On 01/02/2014 04:39:44 AM Thu, John Frankish wrote:

Using balsa-2.5.1 with gtk3, I set up a pop3 account.

2. After successfully downloading the mail, I clicked on "mailbox"
to start reading my inbox, but the moving blue "wait" animation
shows in the bottom left hand corner and no mails are displayed.
Closing balsa and starting from the command line does not give any
error messages and the contents of the inbox are still not displayed.

 As the 300+ emails have been deleted from the server, I would like
to be able to fix this - does anybody have any trouble-shooting hints?

Is the mailbox file stored somewhere with slow access?  An mbox file
of that size should be read from a local drive in a second or two at most.

The mailbox file is stored on a local drive

Does 'top' show Balsa using 100% cpu?

No, about 12%, which equates to one cpu core

If so, it may be stuck in a loop parsing the file; if not, it must be
blocked from some action.  You could try running under gdb, interrupt
it with ctrl-C, and get the stack trace with 'bt'--that might show
what Balsa was trying to do.  Write back with what you see...

Not too many clues from gdb, but here it is anyway:

$ gdb balsa

(gdb) run balsa
Starting program: /usr/local/bin/balsa balsa
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7fff4059f000
warning: Could not load shared library symbols for
Do you need "set solib-search-path" or "set sysroot"?
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be 
** Message: init gpgme version 1.4.3
** Message: protocol OpenPGP: engine /usr/local/bin/gpg2 (home (null), version 2.0.22)
** Message: protocol CMS: engine /usr/local/bin/gpgsm (home (null), version 2.0.22)
** Message: protocol GPGCONF: engine /usr/local/bin/gpgconf (home (null), version 2.0.22)
** Message: protocol Assuan: engine /home/tc/.gnupg/S.gpg-agent (home !GPG_AGENT, version 1.0)
** Message: OpenPGP protocol supported
** Message: CMS (aka S/MIME) protocol supported Network is available
(1388752939) [click on inbox, nothing happens] ^C Program received signal SIGINT, Interrupt.
0x00007f75a2f53dfd in poll () from /lib/
(gdb) bt
#0  0x00007f75a2f53dfd in poll () from /lib/
#1  0x00007f75a3676add in ?? () from /usr/local/lib/
#2  0x00007f75a3676c0a in g_main_loop_run () from /usr/local/lib/libglib-
#3  0x00007f75ad87404a in gtk_main () from /usr/local/lib/
#4  0x00000000004afbcc in ?? ()
#5  0x00007f75a3f52cdc in ffi_call_unix64 () from /usr/local/lib/
#6  0x00007f75a3f52970 in ffi_call () from /usr/local/lib/
#7  0x00007f75a416980a in g_cclosure_marshal_generic () from /usr/local/lib/
#8  0x00007f75a417077d in g_closure_invoke () from /usr/local/lib/libgobject-
#9  0x00007f75a4165afb in ?? () from /usr/local/lib/
#10 0x00007f75a416c717 in g_signal_emit_valist () from /usr/local/lib/
#11 0x00007f75a417efde in g_signal_emit () from /usr/local/lib/libgobject-
#12 0x00007f75a45e1c4e in g_application_run () from /usr/local/lib/libgio-
#13 0x0000000000426d6e in ?? ()
#14 0x00007f75a2eb9468 in __libc_start_main () from /lib/
#15 0x0000000000426db1 in ?? ()

To add to this, I tried using claws-mail "import mbox folder" and was able to successfully import the balsa 
inbox without errors.

I tried two tests to export the inbox from claws-mail to mbox format:

1. All emails - balsa was unable to open the inbox

2. All emails less 9 mails that showed "no subject" and "no date", which I deleted in claws-mail prior to 
export - balsa was able to open the inbox without errors.

So it looks like at least one of 9 "mal-formed" mails stopped balsa from being able to read any of the mails, 
whereas claws-mail had no problems at all.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]