Re: Startup strangeness

On 2009.09.11 20:11, Peter Bloomfield wrote:
Hi Jack:

On 06/12/2009 04:52:33 PM Fri, Jack Ostroff wrote:
On Balsa 2.3.28 (although it was the same on several previous versions) balsa seems to have latched on to a particular mailbox to open at startup, no matter which one I'm in when I close, and whetner I close by closing the window or using Ctl-q. "balsa -i" has no effect, and "balsa -o folder" gives me a popup 'Couldn't open mailbox "folder"' and I've tried several of my folders with the same result (all mbox format). I'm on Gentoo Linux, and I can't find any mention of problems on their forum or bugzilla.

Any thoughts on how to troubleshoot or figure out what's going on?

I just pushed to git-master some changes that should help. Specifically, the mailbox that you are working in when you exit Balsa is the first opened when you restart it, and any others opened on restart will not flash by, so you can start work immediately.

If you don't have "View: Show Mailbox Tabs" checked, you might want to check it from time to time. You may find that you're opening some mailboxes that haven't been used in a long time, which can only slow Balsa's response at open time.



Thanks. I finally got the git-master checked out and compiled. The opening is certainly visually quieter (if that makes sense) - no flashing between open mailboxes. However, it does not seem to remember which mailbox was the one displayed when I closed balsa. (It IS supposed to do this, right?) It also doesn't seem to remember the tab order of open mailboxes (if I drag a tab to a different position) but I don't know if it even tries to do that. I'm not sure what order the tabs are in - but it's not alphabetical, and it seems to always display the mailbox on the first tab, with the exception that if I close Inbox before quitting, that is the last tab and the one displayed. The -i tab seems irrelevant if it always opens the inbox. The -o tab always says that it can't open that mailbox - even if that mailbox is already open (am I specifying the name incorrectly?).

Anything else I can test or try?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]