Re: PGP signing/decoding problem



On 2003.06.17 21:19, Albrecht Dre wrote:
> Am 17.06.03 19:16 schrieb(en) Antoine Delvaux:
>> But, I cannot sign an outgoing message nor can I decode an incoming 
>> message being encoded with my public key.  That is, everytime Balsa 
>> ask me for my passphrase, I type it correctly in the popup window 
>> (I've tried it dozens of times) but Balsa never accept it.
> 
> Do you have by chance any 8-bit characters (like ) in your 
> passphrase? When I now think about that, it will not work with balsa, 
> as all widgets (like the input) take utf-8 encoded characters, whereas 
> gnupg uses plain 8-bit (does ist?) with whatever encoding you use 
> (probebaly iso-8859-15). Guess you found a bug...

Indeed.

> BTW, how does (if you have it installed) Seahorse behave? Do they 
> accept ypur passphrase? If so, It might be possible to steal the code 
> from them...

I've just tried Seahorse, GNU Privacy Assistant and Nautillus, all fail 
to recognize my passphrase.

I'm not a charset-encoding expert, but would it be possible to enter some 
other key so that the correct char, utf-8 encoded, is entered in the 
widget ?

What could be the other solutions to this problem ?  Should I report a 
bug to Seahorse and/or GNU Privacy Assistant ?

Gnome-1 applications behave correctly, I suppose it's because the Gnome-1 
widgets don't use utf-8 encoding.

Antoine.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]