Re: Nameserver calls - libesmtp problem?

Am 29.06.2001 11:11:29 schrieb(en) Brian Stafford:
> I cannot emphasise enough that if "localhost" is specified as a hostname
> name server queries *will be made to resolve it*.  I have stated this many
> times now.  Furthermore, despite what people expect, this is correct
> behaviour
> of a conformant resolver.  In case anyone has still missed the point,
> specify "localhost:25" as ":25" to avoid a DNS query.  I made an effort to
> ensure this feature worked correctly.  Please make the effort to use it.

Following a hint by Carlos, I now have these two lines in /etc/hosts:       localhost       localhost.localdomain
::1             localhost       localhost.localdomain

Now, for local recipients (like root@localhost) your test program does *not*
trigger the dial in any more, with both --host=:25 and --host=localhost:25. So
if the resolver call is done as you explained, the config now seems to be
correct, as it apparently first looks into the local files. It connects
correctly with sendmail, and the mail is delivered correctly, too.

However, for *remote* recipients, now sendmail makes the querey between the

S: 250 2.1.5 <>... Recipient ok

Looks as if I now should try to fix the sendmail configuration, or better
switch to something else, as you said before. Postfix, maybe? I just wonder
why it worked before (and still if I use sendmail and balsa without libesmtp).
I guess I will *never* understand this program...

Thanks a lot for your help!

Cheers, Albrecht.

    Albrecht Dreß  -  Monschauer Straße 22  -  D-53121 Bonn (Germany)
      Phone (+49) 228 6199571  -  E-Mail

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]