Re: [xslt] confusing error message "function format-date bound to undefined prefix date"

Oh, I'm so sorry that I didn't put more effort into writing this
question. The information I had at that point confused me, it seems.

1. We used the date function provided by, as you pointed out.
2. My version was libxslt <1.1.24, libxml 2.7.3>, his version was
<libxslt 1.1.17, libxml 2.6.26>.
3. Our application worked on his setup flawlessly.
4. Our application errored on my setup (function format-date bound to
undefined prefix date")
5. The date: and str: prefixes were defined in <xsl:stylesheet> in the
same file as the function calls.
6. Removing the str:replace() call made the error go away.
7. Moving the result of the str:replace() operation into a variable
and using that made the error go away.

So I concluded from 2),3) and 4) that in some recent libxml/xslt
update, something got changed around, perhaps becoming more strict.
Since 6) and 7) showed that the first parameter was apparently the
culprit, and I saw that we weren't using str:replace function the way
its signature describes, ...

But your example scripts demonstrate that this is not the case. You
combined the two functions in the same expression successfully while
an identically constructed errors out in our application.

I thought that it might be because we're including the date function
in a higher-level template file, but I wrote a test case for that and
it worked too. So now I'm in the process of raking our application's
xslt code down to a minimal test case. This will hopefully reveal the
root cause.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]