[xslt] BUGs introduced in bugfix releases???

Hi all,

I'm was using libxml-2.6.18 and libxslt-1.1.13. In this combination (sorry, I 
didn't test that much, cuz' my CPU is on load) it obviousely definitely 
raises a bug somewhere (I gonna describe below).
However, I know that it worked before, and though I downgraded to 
libxml-2.6.16, and libxslt-1.1.12 and it's working again. I did not test any 
other version between those both I'm testing now.


I'm having lots of .xsl files I'm using for theming my portal (within an 
apache module that is using libxml2/libxslt for generating the page).

in my template.xsl (the core stylesheet) I'm having the following part:
  <xsl:param name="iself"/>         <!-- private base uri 
                                         (used for internal sub requests) -->
  <xsl:param name="sid"/>           <!-- user session id -->

  <!-- std in-session arguments -->
  <xsl:variable name="stdsargs">
    <xsl:value-of select="$stdargs"/>
    <xsl:if test="$sid != ''">
      <xsl:value-of select="$sid"/>

in character.xsl I'm having the following part:
  <xsl:variable name="XmlCharsRequest">
    <xsl:value-of select="$iself"/>
    <xsl:value-of select="$stdsargs"/>
    <xsl:value-of select="$charName"/>

  <xsl:variable name="XmlGetCharRequest">
    <xsl:value-of select="$iself"/>
    <xsl:value-of select="$stdsargs"/>
    <xsl:value-of select="$charName"/>

Now, in character.xsl I'm having the following inside an xsl:template element:

  <xsl:template name="page_viewchar">
    <xsl:variable name="xgetchar" 
    <xsl:variable name="xchars" select="document($XmlCharsRequest)/YaCSInfo"/>

    <div class="DocumentBody">
      <h1>debug-01: [<xsl:value-of select="$XmlGetCharRequest"/>]</h1>
      <h1>debug-02: [<xsl:value-of 

Now, having a look at my debug-01 and debug-02 lines. I'm debug-printing the 
contents of the XmlGetCharRequest variable. It's complete, that is, it's as 
expected, my fully qualified URL for the internal XML request.
I validated the URL by copy'n'pasting it into my browser, and it worked just 

Now, the debug-02 line, I'm expecting the output "[1]" but I get "[0]", that 
is, that it obviousely did anything wrong inside the document() function. I 
used ngrep to sniff the network traffic between the apache module and the 
internal request to itself (the webserver) and saw, that I simply removed 
the ?name=trapni part from the URL. That's definitely a bug.

Now, downgrading to the version I specified above worked well. So, the bug 
must be on your side (somewhere).

Can anybody verify this? (with a shorter example maybe, since I can't expect 
you to eat my whole .xsl file bunch ;)

If you can verify this bug, please fix it.

Ah, I obviousely forgot to say, that the bug obviousely only occurs on my 
devbox that is an Athlon64 (completely in/for 64bit mode compiled) and it 
doesn't seem to occur on my AthlonMP server (being 32bit though).

Thanks in advance,
Christian Parpart.

Netiquette: http://www.ietf.org/rfc/rfc1855.txt
 23:41:23 up 13 days, 12:47,  0 users,  load average: 0.17, 0.29, 0.40

Attachment: pgpUr5fRNXfVH.pgp
Description: PGP signature

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]