Re: [xml] runtest mystery bug: name2.xml error case regression test

On Tue, 11 Sep 2012, Daniel Veillard wrote:

Really I tried again today to make sure, and even with an out of tree build and your patch applied, it just work as expected for me on Fedora 17 x86_64,

thinkpad:~/tmp/build -> ./runtest
## Error cases regression tests
Total 11 tests, no errors
thinkpad:~/tmp/build ->

 I can try 20 times it's always the same,

I got a VM of FC17 up and running, and the test passes for me every time there too. Try as I might, I can't make it fail.

At this point, I'm not sure *what* I have. The test fails consistently on my work desktop (Ubuntu 11.10), yet if I build on an 11.10 live desktop with the same compiler, it works. If I copy over the binary from my work system to the live desktop, it fails. But if I copy that same binary to the FC17 VM, it works. (Note that other systems at my office, with older versions of Ubuntu, give the same error; it's not just my machine.)

If there were a good way of getting an execution trace, I could do a diff between what's happening on my system versus on FC17. Doing "step" in a loop in GDB doesn't work, however, returning clearly bogus results (e.g. a call to __xmlRaiseError() that doesn't occur in a normal debugger run).

This will have to be left unresolved for now, until/unless I can get a better handle on it :-(


Daniel Richard G. || danielg teragram com || Software Developer
Teragram Linguistic Technologies (a division of SAS)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]