Re: [xml] libxml2 run time question

Thanks a lot for your reply.
Yes, I have another on the system, and i removed it already, and now it has the only in /usr/lib and l see ldd to check, it shows that the used is from /usr/lib
But when i run the code, it seems that the function calling the libxml, such as the xmlXPathCompile does not run correct.
This code is ok to run on windows and Unix using the corresponding libxml2.
But when it runs on Fedora core 6, it has such problem.
Is there some special setting up in Fedora core 6 to run the pragramme? for example, some searching path to setup?
Thank you!

On 1/15/07, Daniel Veillard <veillard redhat com> wrote:
On Mon, Jan 15, 2007 at 03:29:22AM -0500, Daniel Veillard wrote:
> On Mon, Jan 15, 2007 at 01:33:12PM +0800, Yuan Ni wrote:
> > Hi everyone,
> > My code havs used the libxml2 2.6.27 on the rpm for redhat i386 on Fedora
> > core 6.
> > The compile and link is ok.
> > However, when i run the code, it gives me the following error message :
> > error while loading shared libraries: ELF file data encoding
> > not little-endian
> > does it means that the library i used does not match my architecture?
> > How to deal with this problem?
>   Check that you have no other in your environment than the
> ones in /usr/lib . A lot of things in fedora depends on libxml2, and if
> the library was really corrupted as this seems to indicate a lot of other
> things would probably fail (e.g. when running the Gnome environment).

  use ldd on your binary to find out where it's picking up from.


Red Hat Virtualization group
Daniel Veillard      | virtualization library
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]