Re: [xml] Libxml 2.6.26 XML parsing bug

On Fri, Jul 07, 2006 at 05:10:52PM +0200, Kris Breuker wrote:
Op 7-7-2006 15:51 heeft Daniel Veillard het volgende geschreven:
paphio:~/XML -> xmllint --noout fotoarchief.xml
paphio:~/XML -> /usr/bin/xmllint --noout fotoarchief.xml
paphio:~/XML -> valgrind xmllint --noout fotoarchief.xml
paphio:~/XML -> md5sum fotoarchief.xml
5eb8ec29c960c5b7cb53df6b6dfa2a84  fotoarchief.xml
paphio:~/XML ->

When I run the Windows precompiled binary xmllint.exe I get the same 
results, and when I run a local Linux build of xmllint I also get the 
parser errors.

However, my fotoarchief.xml file generates the following MD5:

btc1:/tmp/libxml # md5sum fotoarchief.xml
59b144b46156afb6a627fc589751386e  fotoarchief.xml

which is not the same as what you got, but when I save it in Unix format 
(my version is in Windows format), I get:

btc1:/tmp/libxml # md5sum fotoarchief_unix.xml
5eb8ec29c960c5b7cb53df6b6dfa2a84  fotoarchief_unix.xml

I have attached tgz'ed version of my version fotoarchief.xml, but just 
converting from Unix to Windows format may do the trick as well.

  Ah ah, now I can reproduce it:

paphio:~/XML -> xmllint --noout fotoarchief.xml
fotoarchief.xml:537: parser error : Comment not terminated
paphio:~/XML -> cp fotoarchief.xml fotoarchief2.xml
paphio:~/XML -> dos2unix fotoarchief2.xml
dos2unix: converting file fotoarchief2.xml to UNIX format ...
paphio:~/XML -> xmllint --noout fotoarchief2.xml
paphio:~/XML ->

 Clearly there is a low level libxml2 parser bug, congratulation !
 I will try to look at it during the week-end, this kind of errors 
have become quite uncommon, interesting ! Tanks a lot for reporting it !


Daniel Veillard      | Red Hat
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]