Re: [xml] Installing libxml - new mail

'configure', 'make' and 'make install' report no errors for libxml, but when I
try to compile php with the --with-xsl option 'make' fails with the following

ext/dom/document.lo(.text+0x24f3): In function `zif_dom_document_validate':
/root/php-5.0.5/ext/dom/document.c:1752: undefined reference to
undefined reference to `xmlFreeValidCtxt'
ext/dom/document.lo(.text+0x2a29): In function `dom_load_html':
/root/php-5.0.5/ext/dom/document.c:1978: undefined reference to
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

--- Daniel Veillard <veillard redhat com> wrote:

On Tue, Nov 22, 2005 at 10:38:06AM -0800, Todd Siegel wrote:

I downloaded, compiled and installed libxml on my linux box so I can
PHP with XSL support.  When I run 'make tests' it hangs at the following:

## Relax-NG Python based test suite 1
## Relax-NG Python based test suite 2
## XML Schemas datatypes Python based test suite
## It is normal to see 10 errors reported
found 1035 test instances: 1024 success 11 failures
make[1]: Entering directory `/root/libxml2-2.6.22/xstc'
Rebuilding script (NIST)
./Tests/Metadata/NISTXMLSchemaDatatypes.testSet:8: warning: xmlns: URI
TestSuite is not absolute

  it is not hang it is going through more than 30,000 schemas regression

I tried compiling PHP anyway and it failed.  Also, I have successfully

  no idea what this means. "it failed" how could we possibly help with
such a report.

installed libxml on another box.

Kernel version: 2.4.20
GCC version: 3.2.2

  the kernel and gcc version are totally unrelated.


Daniel Veillard      | Red Hat
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]