Re: [xml] libxml2-2.6.22 test suite

On Sun, Dec 04, 2005 at 05:12:57PM -0600, Bruce Dubbs wrote:
I have been validating packages for the Beyond Linux From Scratch
project and have run into a problem with the libxml2 test suite.

When building with:

./configure --prefix=/usr --with-history &&

the process completes without error.  However, when I run `make check`
the process runs until the section:

## Catalog regression tests

at this point, the command lt-xmlcatalog runs without stopping.  At
least I let it run for an hour on a 3GHz x86 system.  I have tried this
using gcc3 as well as gcc4 with similar results.

Upon further analysis of the Makefile, the process is hanging for me
when doing ./test/catalogs/whitex.script.  If I rename this script so it
does not run, the test suite finishes with what appears to me as some
minor errors listed below.

Any insight into these issues, especially the hang, will be appreciated.

  Excep that you XML system catalog lacks entries for DocBook the logs
are normal. But I have no idea why your build fails. That's the first
time I heard of such a problem.


Daniel Veillard      | Red Hat
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]