Re: [xml] xmllint segfault in recurring reference of xs:extension

On Fri, Apr 16, 2004 at 12:34:59PM +0900, taihei goi wrote:
I'm using libxml2.6.8 on redhat7.3.
I got a segfault when I used xmllint with --schema option.
so I report here.

The schema file is:
<?xml version="1.0" encoding="utf-8" ?>
<xs:schema xmlns:xs="";
targetNamespace="test" xmlns:t="test">
<xs:complexType name="comp1">
   <xs:extension base="t:comp1">

This schema contains recurring reference.
But I didn't get segfault similar xs:restriction schema file.
And this didn't occur on any other schema component that uses recurring
reference as far as I test.
(memberTypes on xs:union,itemType on xs:list,base on xs:restriction,
ref on xs:element,xs:group,xs:attributeGroup)

  Okay, fixed in CVS, the error is reported ... 3 times, I don't know
why the type tried to be fixed 3 times. That could probably be solved 
but at least there is a fimple fix around the problem (stack overflow).

  thanks for the report,


Daniel Veillard      | Red Hat Desktop team
veillard redhat com  | libxml GNOME XML XSLT toolkit | Rpmfind RPM search engine

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]