[xml] RE: xml digest, Vol 1 #619 - 4 msgs


I agree that "LIBXML_PUBLIC" would be a much clearer and more descriptive
term than "LIBXML_DLL_IMPORT". 

As a Windows developer, I would vote for including this in all the
declarations, but I realize that others will probably disagree. Are there no
platforms other than Windows where it would be useful to mark "public"
functions and data in this way? 

Reply-To: Igor Zlatkovic <igor stud fh-frankfurt de>
From: Igor Zlatkovic <igor stud fh-frankfurt de>
To: <xml gnome org>
Subject: Re: [xml] Building libxml2 as a DLL under MinGW MSYS
Date: Sat, 28 Sep 2002 19:49:01 +0200
Organization: UAS Frankfurt

One thing: The name 'LIBXML_DLL_EXPORT' is somewhat misleading. An user
has never seen Windows rightfully asks herself what that should be. Should
this thing ever be used more than now, I would urge to rename it to
something more understandable, such as LIBXML_PUBLIC, for example.

Whatever its name, putting it in front of every function's declaration is
unlikely to happen. Only Windows can profit from this and all other
platforms would have to endure a header uglification. We had discussed
this a while ago. There is a hard resistance at least as long as there is

Any objections, suggestions, cries, cheers?

Plenty of cheers. Libxml2 is quite an achievement.

Eric Zurcher
CSIRO Livestock Industries
Canberra, Australia
Eric Zurcher csiro au

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]