[xml] Fw: Kannel installation problem with libxml2

I want to the rpm packages listed on ftp://xml.org/ are for which distribution of Linux, I want libxml2-2.3.4 and libxml2-devel rpms for Redhat Linux 6.2
I'm also explainig my problem as follows, please comment on that
----- Original Message -----
From: SMS
Sent: Thursday, March 22, 2001 1:23 PM
Subject: Re: Kannel installation problem

I'm following your instructions in installing kannel, first thingI found that libxml2-2.3.4's rpm is not available for RedHat Linux 6.2 or better. the rpm  Iinstalled was for another distribution of Linux. So I unstalled it , also uninstall the libxm version 1.x.x which comes with Redhat.  I then install the libxml2-2.3.4 from source by ./configure , make and make install commands.  it's installed in /usr/local/Iib I then check the  /etc/ld.so.conf which contains following variables




How can I update the environment var LD_LIBRARY_PATH. in libxml FAQ they say you may have to rerun ldconfig or similar utility to update your list of installed shared libs. I ran ldconfig but then  I saw in ld.so.conf that /usr/local/lib is not added so I manually entered the path there. ran ldconfig again and tried to install Kannel but it gives following errors.

libxml2 >= 2.2.0 is needed by kannel-1.0.2-1

libxml2 < 2.3.0 is needed by kannel-1.0.2-1

libxml.so.2 is needed by kannel-1.0.2-1

please guide me what to do next as its reallt frustrating now, someone who istalled it on RedHat Linux 6.2 please tell me the exact steps to proceed.



----- Original Message -----
From: "Chun Yan See" <chunyan see n2nconsulting com>
Sent: Wednesday, March 21, 2001 7:23 PM
Subject: RE: Kannel installation problem

    Just a advice, try not to cc to someone who is already
    on the list or else there will be duplicate mails received.
    But I think Kannel might have fixed that already. :)
    Ok, back to your problem. You have to be abit more familar
    with Unix environment to maintain Kannel well.
    There are a few ways to solve your problem.
    Assuming you have already installed the libxml, check where you
    have installed into. Most likely it is in /usr/local/lib.
   Check if ld.so.conf includes that path. If not, you can try updating
   the environment var LD_LIBRARY_PATH.
   Or put the libxml files into the path where ld.so.conf specified.
   There is also a unix command which you can use as root. man ldconfig
   to find out more.
   After doing all these, retry the kannel installation again. Have fun.

-----Original Message-----
From: Hassan
Sent: Wed 3/21/2001 9:49 PM
To: Chun Yan See;
devel kannel org
Subject: Kannel installation problem


I'm trying to install Kannel 1.0.2 on RedHat Linux 6.2,  I also
installed libxml2-2.3.4-1 but it kept on giving the error

libxml2 < 2.3.0 is needed by kannel-1.0.2-1
libxml.so.2 is needed by kannel-1.0.2-1

please someone guide me on this


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]