[Vala] [ANNOUNCE] Vala 0.25.1 - Compiler for the GObject type system
- From: Jürg Billeter <j bitron ch>
- To: vala-list gnome org, vala-devel-list gnome org
- Cc: gnome-announce-list gnome org
- Subject: [Vala] [ANNOUNCE] Vala 0.25.1 - Compiler for the GObject type system
- Date: Wed, 23 Jul 2014 12:03:04 +0200
We are pleased to announce version 0.25.1 of Vala, a compiler for the
GObject type system.
Vala 0.25.1 is now available for download at:
http://download.gnome.org/sources/vala/0.25/
Changes since 0.24.0
* Support explicit interface method implementation.
* Support (unowned type)[] syntax.
* Support non-literal length in fixed-size arrays.
* Mark regular expression literals as stable.
* GIR parser updates.
* Add webkit2gtk-3.0 bindings.
* Add gstreamer-allocators-1.0 and gstreamer-riff-1.0 bindings.
* Bug fixes and binding updates.
Vala is a programming language that aims to bring modern programming
language features to GNOME developers without imposing any additional
runtime requirements and without using a different ABI compared to
applications and libraries written in C.
valac, the Vala compiler, is a self-hosting compiler that translates
Vala source code into C source and header files. It uses the GObject
type system to create classes and interfaces declared in the Vala source
code.
More information about Vala is available at
http://www.vala-project.org/
The Vala Team
---
Al Thomas (1):
codegen: Uppercase strings in ASCII, otherwise broken for some locales
Christian Persch (1):
glib-2.0: Allow null hooks for OptionGroup
Evan Nemerson (59):
gdk-pixbuf-2.0: make Pixbuf.save_to_stream variadic
gtksourceview-3.0: update to latest git
glib-2.0: add OptionContext.parse_strv
gtk+-3.0, gtk+-2.0: make TargetList constructor argument nullable
gio-unix-2.0: fix DesktopAppInfo.list_actions return value
pango: update to latest git
Add webkit2gtk-3.0 and webkit2gtk-web-extension-3.0 bindings.
webkitgtk-3.0: add metadata file
gdk-pixbuf-2.0: update to latest git
atk: update to 2.13.1~d44970bd
goocanvas: mark as deprecated
gudev-1.0: update to latest git
gdk-3.0: update to 3.13.1~701adf81
codegen: put exception checks inside of a G_UNLIKELY
libsoup-2.4: deprecate Buffer.new and MessageBody.append
gstreamer-1.0: update to latest git.
Update GIR-based bindings.
girparser: support return_void metadata argument
girparser: improve support for changing symbol types away from instance
girparser: don't deprecate children of deprecated containers
json-glib-1.0: update to 1.0.2
girparser: handle multiple identifier-prefixes in namespaces
glib-2.0: add HashTable.get_keys_as_array
glib-2.0: remove HashTable.get_keys_as_array
girparser: only replace ref/unref funcs with better matches
gtk+-3.0: set Editable type_cname
gstreamer-1.0: update to 1.3.2.1~d99e6215
gtk+-2.0: add WidgetClass.set_scroll_adjustments_signal binding
gobject-2.0: make ObjectClass.list_properties transfer container
glib-2.0: mark many constants as const instead of static
glib-2.0: don't use the container type's generic in static methods
gobject-2.0: make TypeClass non-reference-counted
Revert "gobject-2.0: make ObjectClass.list_properties transfer container"
gio-2.0: callbacks in ActionEntry must not have a target
glib-2.0: add GLib.HashSet
glib-2.0: add HashTable.take and length
glib-2.0: add static methods back into Sequence, marked as deprecated
gio-2.0: maintain backwards compatibility with old ActionEntry binding
cairo-xcb, xcb-iccm, xcb: deprecate in favor of vala-extra-vapis
glib-2.0: rename HashSet to GenericSet
Use ascii_up/down instead of utf8 up/down when generating identifiers
glib-2.0: add non-null support for string.joinv
posix: the atexit callback does not have a target
gstreamer-rtsp-server-1.0: update bindings
gstreamer-1.0: update bindings to latest git
glib-2.0: mark PtrArray as deprecated in favor of GenericArray
glib-2.0: change constructor for GenericArray with glib-2.0 >= 2.30
girwriter: fix *Private type name for nested classes
girwriter: fall back on gir_namespace if GIR name is not available
vala.m4: don't escape modules argument to VALA_CHECK_MODULES
gstremaer-rtsp-server-1.0: add gstreamer-net-1.0 to deps
gstreamer-rtsp-server-1.0: update to fix C header filename
webkit2gtk-3.0, webkit2gtk-web-extension-3.0: update to 2.4.3
codegen: cast instead of trying to guess *_CLASS macro name
librsvg-2.0: remove from gir-bindings target
bindings: update GIR-based bindings to latest git
gtk+-3.0: make TextIter.copy return value nullable
Add .dir-locals.el (emacs configuration file)
gstreamer-video-1.0: Info.finfo is unowned
Florian Brosch (5):
glib-2.0: Fix bindings for g_hash_table_size
Warn if -X is used in combination with -C
Warn if --save-temps is used in combination with -C
Warn if C files are used in combination with -C
Warn if -o is used in combination with -C
Jürg Billeter (3):
Bump version suffix
Mark regular expression literals as stable
Release 0.25.1
Kyrylo Polezhaiev (1):
libpq: Fix syntax error
Lasse Schuirmann (1):
libarchive: Update to version 3
Luca Bruno (24):
atk: Update and fix metadata
girparser: Support interface aliases
libnotify: Updated to 0.7.6-3-gda49c8c
gdl-3.0: Update after the GdkEvent change from struct to class
Remove gedit from all-bindings as it will be shipped upstream
geocode-glib-1.0: update to 3.12.0-5-g7eb1490
gobject-introspection-1.0: regenerate according to vala-girs
girparser: reset cheader_filenames before parsing a gir
gtk+3.0: fix Application.set_accels_for_action array parameter
Support (unowned type)[] syntax for transfer-container arrays
Fix writing vapis with (unowned type)[]
girparser: Make array element type owned by default
Revert "girparser: Make array element type owned by default"
Fix gir and gidl bindings due to (unowned type)[] arrays
Support explicit interface methods implementation
gobject: Add Binding.unbind
codegen: Simplify field initialization for struct types
girparser: use identifier prefix from GIR when appropriate
glib-2.0: support Variant objv
gvariant module: Fix memory leak when deserializing hashtables with gvariant
non-nullable: Accessing array methods is safe when the array is null
Call g_signal_handlers_destroy on gtypeinstance finalizer
codewriter: Do not write (unowned string)[] for constants
Fix previous 6c36eb4 commit
Maciej Piechotka (1):
Hide internal methods in ABI
Raul Gutierrez Segales (1):
glib-2.0: add accessor for GArray's data field
Rico Tzschichholz (23):
gtk+-3.0: Update to 3.12.0
geocode-glib-1.0: Update to 3.12.0
clutter-1.0: Update to 1.18.0
cairo: Update some enums and consts
Add tests for enums annotated with [Flags]
x11: Don't use camel-cased names for methods
gio-2.0: Update to 2.41.0~
gtk+3.0: Update to 3.13.0~
gdk-3.0, gtk+3.0: Update to 3.13.1
gtk+-3.0: Perform missing rebuild
gtk+3.0: Update to 3.13.1+
gdk-3.0: update to 3.13.1~a61a11a4
gdk-3.0, gtk+-3.0: update to 3.13.1~3f140d53
gstreamer-1.0: Add gstreamer-allocators-1.0 and gstreamer-riff-1.0
glib2.0: Mark StaticPrivate as deprecated
gobject-2.0: Bind G_PARAM_EXPLICIT_NOTIFY
gtk+-3.0: update to 3.13.3~200bdf1a
gio-unix-2.0: update to 2.41.0
gdk-3.0, gtk+-3.0: Update to 3.13.3
gtk+-3.0: Update to 3.13.4~b238d556
gtk+-3.0: Update to 3.13.4~f2c6b31e
gtk+-3.0: Application.get_menu_by_id returns owned value
gtk+-3.0: Update to 3.13.5
Robert Ancell (16):
x11: Add some missing API
xcb: Set correct C name for Xcb.ScreenIterator.next
xcb: Fix visuals iterator methods
xcb: Add binding for xcb_connection_has_error
xcb: Fix depth iterator methods
xcb: Add missing fields to Xcb.Setup, Xcb.Screen and Xcb.VisualType
xcb: Add methods to access pixmap formats
xcb: Remove unnecessary padding fields
xcb: Missing EnterNotifyEvent, LeaveNotifyEvent, KeymapNotifyEvent, VisibilityNotifyEvent,
ReparentNotifyEvent, GravityNotifyEvent, CirculateNotifyEvent, PropertyNotifyEvent, SelectionNotifyEvent,
ColormapNotifyEvent, MappingNotifyEvent classes
xcb: Add Xcb.Connection.get_atom_name
xcb: Add Xcb.Connection.create_pixmap
xcb: Add drawing API
xcb: Add more methods and use Vala types for accessing data
xcb: Add helper methods for GetPropertyReply
xcb: Replies are nullable and errors are optional
compiler: Support configurable pkg-config command so can cross compile
Ryan Lortie (3):
gtk+-3.0: fix flowbox selection foreach API
gtk+-3.0: add new GtkListBox selection API
girparser: grok "nullable"
Simon (1):
Support non-literal length in fixed-size arrays
Simon Werbeck (5):
codegen: Do not generate generic destroy func for non-disposable structs
codegen: Fix local and field names starting with a digit
Set G_SIGNAL_DEPRECATED on annotated signals
Fix comparison of nullable value types
Detect format string errors when instancing errors
Stefano Facchini (1):
glib: Add G_SOURCE_CONTINUE/G_SOURCE_REMOVE
Timm Bäder (1):
gtkmodule: Error out on malformed signal definition
Yaakov Selkowitz (1):
clutter-gst-1.0: fix deps
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]