[Vala] naming issue with abstract async functions



Hello

I have the following programm:

public abstract class AbcAbstr : GLib.Object {
  public abstract async void test_async();
}

public class ABC : AbcAbstr {
  public override async void test_async() {
    print("test2\n");
  }

  public static void main() {
    var abc = new ABC();
    abc.test_async();
    new GLib.MainLoop().run();
  }
}

The compilation leads to the following problem:

/home/me/Desktop/testasync.vala.c: In function
‘abc_abstr_test_async_finish’:
/home/me/Desktop/testasync.vala.c:93: error: ‘AbcAbstrClass’ has no
member named ‘test_async_finish’
error: cc exited with status 256
Compilation failed: 1 error(s), 0 warning(s)


If I change the function name from "test_async" to "test_asyn" it
works. 
Is that a bug or is this something that is coming from a design towards
the usage with gio's functions? 

best regards
Jörn




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]