Re: [Vala] libgee on Windows

I tried running configure, make, make install from cygwin but it failed at configure. :( Appending 
--no-undefined on the gcc compile command also failed.
From: mail jensge org
To: vala-list gnome org
Date: Tue, 8 Sep 2009 09:08:44 +0200
Subject: Re: [Vala] libgee on Windows

Am Montag, den 07.09.2009, 13:30 -0500 schrieb Mr. Maxwell .:

pkg-config --libs glib-2.0 produces -LD:/vala-0.7.4/lib -lglib-2.0 -lintl
When I used that as the link option the linking still failed with the same errors. I tried to create a 
batch file with this as the contents and it also failed with the same errors. (it's all one line)gcc 
-shared -o libgee.dll D:\libgee-0.3.0\gee\abstractcollection.o D:\libgee-0.3.0\gee\abstractlist.o 
D:\libgee-0.3.0\gee\abstractmap.o D:\libgee-0.3.0\gee\arraylist.o D:\libgee-0.3.0\gee\collection.o 
D:\libgee-0.3.0\gee\functions.o D:\libgee-0.3.0\gee\hashmap.o D:\libgee-0.3.0\gee\hashset.o 
D:\libgee-0.3.0\gee\iterable.o D:\libgee-0.3.0\gee\iterator.o D:\libgee-0.3.0\gee\linkedlist.o 
D:\libgee-0.3.0\gee\list.o D:\libgee-0.3.0\gee\map.o D:\libgee-0.3.0\gee\readonlycollection.o 
D:\libgee-0.3.0\gee\readonlylist.o D:\libgee-0.3.0\gee\readonlymap.o D:\libgee-0.3.0\gee\readonlyset.o 
D:\libgee-0.3.0\gee\set.o D:\libgee-0.3.0\gee\treemap.o D:\libgee-0.3.0\gee\treeset.o -LD:\vala-0.7.4\lib 
-lglib-2.0 -lintlAny ideas?

Sorry, but I think libgee compiles on mingw by using the normal
"configure, make & make install" triumvirate. (apart from not building a
shared library due to missing -no-undefined on win32 which is easily
fixable, patch follows)

Vala-list mailing list
Vala-list gnome org

HotmailĀ® is up to 70% faster. Now good news travels really fast.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]