Re: [Utopia] Not sure if this is the correct mailing list or not - HAL and G-V-M

On Mon, 2005-07-25 at 10:43 -0500, Steev wrote:
> Jeffrey Stedfast wrote:
> > you needed to ./configure --with-mount-command="/usr/bin/pmount-hal %h"
> > --with-unmount-command="/usr/bin/pumount %d"
> > 
> > Jeff
> I have also tried with this - I have tried patching the configure script
> so that the mount command is passed %h, I have also attempted to pass
> "%h -e" which is what Ubuntu passes with gnome-volume-manager 1.2.0

you completely lost me here... in what way does configure need to be
"fixed"? it sounds like you're doing something wrong.

> No matter what though, even after a reboot, when I start up Gnome, if
> the USB Hard drive is plugged in already, I get the No device for
> udi:.... error.  Unplugging it and plugging it back in *does work* now
> that I pass %h, but I would really like to figure out why it isn't
> mounting automatically at Gnome startup.  Any ideas?

if you get the error: "mount_all: no device for udi=%s: %s", then it

libhal_device_get_property_string (ctx, udi, "block.device", &error) 

is failing... why? I do not know... as the error string is not being
properly set by HAL apparently.

Error: UDI '/dev/sda1' does not exist

that's an error from something other than g-v-m, so no idea what tht is
coming from... perhaps pmount-hal?

Jeffrey Stedfast
Evolution Hacker - Novell, Inc.
fejj ximian com  -

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]