Patch: add proper explicit parameter to PR_Connect
- From: José Dapena Paz <jdapena igalia com>
- To: tinymail-devel-list <tinymail-devel-list gnome org>
- Subject: Patch: add proper explicit parameter to PR_Connect
- Date: Wed, 29 Oct 2008 08:45:58 +0100
Hi,
This patch adds an explicit parameter to PR_Connect for showing the
meaning of timeout 0 (PR_INTERVAL_NO_WAIT).
Changelog would be:
* libtinymail-camel/camel-lite/camel/camel-tcp-stream-ssl.c:
Now we use PR_INTERVAL_NO_WAIT (value is 0) instead of putting
0 as interval parameter for PR_Connect. Should help code
readability.
--
José Dapena Paz <jdapena igalia com>
Igalia
Index: libtinymail-camel/camel-lite/camel/camel-tcp-stream-ssl.c
===================================================================
--- libtinymail-camel/camel-lite/camel/camel-tcp-stream-ssl.c (revision 3789)
+++ libtinymail-camel/camel-lite/camel/camel-tcp-stream-ssl.c (working copy)
@@ -1466,7 +1466,7 @@
cancel_fd = camel_operation_cancel_prfd(NULL);
- if (PR_Connect (fd, &netaddr, cancel_fd?0:(CONNECT_TIMEOUT*1000)) == PR_FAILURE) {
+ if (PR_Connect (fd, &netaddr, cancel_fd?PR_INTERVAL_NO_WAIT:(CONNECT_TIMEOUT*1000)) == PR_FAILURE) {
int errnosave;
set_errno (PR_GetError ());
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]