[Shotwell] Fwd: Migration of Shotwell installation from Ubuntu 13.04 to 14.04

This response below went to the yorba list, not the gnome one, so I’m forwarding it, along with further comment.

I left Shotwell running for a long time in the 14.04 environment, and it eventually settled down, and I think the time spent (and the crashes) were caused by the re-generation of JPG versions of NEF files.

The files are of the form DSC_1234_NEF_shotwell.jpg where the original file is DSC_1234.NEF, but I’ve also found DSC_1234_NEF_shotwell_1.jpg and in rare instances DSC_1234_NEF_shotwell_2.jpg

Thinking that DSC_1234_NEF_shotwell.jpg (“A) and DSC_1234_NEF_shotwell_1.jpg (“B”) were unnecessary duplicates of one another, I tried deleting the B files from the relevant directory, but they were promptly regenerated.

I then tried deleting both A and B files, and this time only A files were regenerated.

My conclusion is that the new installation (Ubuntu 14.04) is failing to recognise the A files created by the 13.04 installation, and is creating a new set of JPGs, appending “_1” to the filename of the newly-created file to distinguish it from the unrecognised one.

I’ve observed that some directories have no JPGs corresponding to the NEF files, some have one or two, and the majority of directories have a full set.

The missing JPGs don’t seem to have any effect on the way Shotwell displays the affected files.

Should Shotwell eventually recognise the NEF files which lack a JPG partner, and create them?


Begin forwarded message:

From: Michael Hendry <hendry michael gmail com>
Subject: Migration of Shotwell installation from Ubuntu 13.04 to 14.04
Date: 17 August 2014 11:39:16 BST

Further to my request for help, I looked here…


…and found “How can I copy my Shotwell library to a new computer?”

As this is essentially what I’m trying to do, I tried it, and didn’t get what I expected.

At first, about 20,000 out of 30,000 images were said to be present in the library, but later the whole library became available. I’m not sure if this happened all at once, or if it was a gradually process.

There have been numerous crashes (Shotwell simply shuts down without warning) and on one occasion my iMac itself became unresponsive and I had to power-cycle it. I also noted a lot of instances of the Shotwell window greying-out and then returning to normal.

There is also an odd phenomenon -  I took two or three images of the speaker at a couple of local functions. Each of these events included one distorted thumb-nail, with the image stretched horizontally and cropped to fit.

Would it be better to install the Shotwell 0.14.1 in my Ubuntu 14.04 virtual machine, transfer the database files, and then upgrade Shotwell by stages to the current version?

Many thanks in advance,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]