Re: Sawfish on ferora 12 has no window frames

On 02/01/10 23:26, Allan Duncan wrote:
On 28/12/09 19:29, Allan Duncan wrote:
On 28/12/09 03:21, Christopher Roy Bratusek wrote:
Am Mon, 28 Dec 2009 00:32:31 +1100
schrieb Allan Duncan<amd2345 fastmail com au>:

I put sawfish (1.6.0) onto an F12 box, and there are no frames around
the windows - no size, close, drag etc. If you go to the Sawfish
Configurator, the Appearance tab has no contents. Xorg 1.7.1, gnome
2.28. Works fine on F11. Xorg 1.6.4, gnome 2.26

Any output in .xsession-errors or stderr, if started from terminal
(`sawfish-config')? Perhaps the themes aren't installed properly.

Wierd. When you attempt to start Appearance you get the message:
*** Remote sawfish error: (error "can't parse tar file listing line (GNU
or Solaris tar required): -rw-r--r-- test-32/test-32 60 2009-12-23 03:47

(test-32 is the user name).

Now, I can "tar -txzf /usr/share/sawfish/1.6.0/themes/gradient.tar.gz"
successfully, but does the error mean that it is trying to use the file
README as an argument list to tar?

OK, I've had the time to play a little further, and it gets wierder still.
First I'll describe my setup to show the context of the error messages.
I have a partition with F11-64, another with F12-32, and a single /home
partition, with the user alland existing in both F11 and F12, so
sawfishrc etc is identical on both boots.
sawfish et al were compiled on F12 under user test-32, and F11 under
user alland.

Now the interesting bit - when I run sawfish-config as user alland on
F12, I get a similar but different error meassage as the one above:
[alland zeus ~]> sawfish-config
*** Remote sawfish error: (error "can't parse tar file listing line (GNU
or Solaris tar required): -rw-r--r-- test-32/test-32 760 2009-12-23
03:47 Elberg-tabbed/INSTALL\012")
[alland zeus ~]>

A different themes tar to the earlier barf.
Note that the owner/group given is that of the compile, not the user
invoking sawfish.

Now that I've got my working home dir on F12, I'll try recompiling
sawfish in the vain hope that the hyphenated user name in the tar files
is the bug.

Vain hope it may have been, but that fixed it. The only substantive system change that I can recollect is a minor update of the compiler. I won't try and pinpoint where the parsing error is, or guess why the user/group is even being parsed in the first place.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]