Re: Debian packages. Critical bugs before releasing 1.6.0

Teika Kazura said:     (by the date of Tue, 27 Oct 2009 20:45:08 +0900 (JST))

> Hi, Janek.
> On Tue, 27 Oct 2009 10:23:35 +0100, Janek Kozicki wrote:
> > What didn't work [in latest GIT version]:
> > 
> > 1) all of my keybindings defined in ~/.sawfish/custom were not there.
> >    Ignored, unused, I'm not sure what exactly went wrong. Because the
> >    file was not cleaned empty. The bindings are still in it. But in
> >    sawfish bindings they are not listed. And they don't work, of
> >    course.
> I now installed the latest, but it works as usual. I don't think
> we have changed in keyboard related part at all since 1.5. Maybe
> some other process, or zombie instance of sawfish is snatching the key
> input?

Perhaps that bug is only affecting me, and I'm acting stupid :) I'll
investigate later. Maybe on Friday.

> > I notice also that the order of variables is switched in
> > ~/.sawfish/custom, the "window matches" are moved to the top of the
> > file. But apart from that the contents of the file is the same.
> Each time you edit options with the configurator, sawfish-config
> (former sawfish-ui), the order changes, so this is not a problem.
> # I control my ~/.sawfish/custom with git, but I always filter it with
> # 'sort', to make the diff meaningful.
> > 2) 9 mouse buttons. I simply could not figure this out. I wanted to
> >    configure xbindkeys to send some keycode when I press a mouse
> >    button. Then simply change the keybindings in sawfish to use that
> >    keycode instead of Button9 and others.
> > 
> >    But I could not get xbindkeys to generate any useful keycode. It
> >    pastes a string in an xterm. No problem. But let's say that I want
> >    a Button9 to generate an XF86AudioStop keycode, or an 0x66 keycode.
> >    I don't know how.
> You've installed xvkbd? The page cited from the wiki says "xbindkeys *or*
> xvkbd", but you need both. Sorry. I'll look for better reference.
> > file ~/.xbindkeysrc
> > 
> > "xvkbd -xsendevent -text "\[XF86AudioStop]""
> > m:0x0 + b:9
> > 
> > This one pastes a string to terminal, when I press Button9:
> Let me report my trial. I've got synaptic (with synaptics driver), and
> I tried button 6 & 7.
> Mine:
> "xvkbd -xsendevent -text "\[Left]"" 
> m:0x0 + b:6
> 1. It seems that -xsendevent can be omitted. I couldn't find the difference.
> 2. I don't know what "m:0x0" means (no modifier?), but it can be omitted.
> 3. It's unstable. I tried it on emacs. It sometimes works as left, but
>    sometimes reported as "Button 6"
> 4. The focus goes away when I press button 6. After I focus the window
>    again with window-cycle, then button 6 is sent to the window. Why?
> 5. After the window is un-focused, my key for raise-lower doesn't
>    recognized.
> 6. When I bind Alt + Escape (toggle-window-shaded), it works. So it
>    depends on the bound text?
> I'll search for more on xbindkeys. That's all for now.

yes, I installed both of them, and I could get a basic functionality,
which confirms that it is installed and it works. But what I get was
very far from the other's "Buttons N" behaviour.

best eragrds
Janek Kozicki                                                         |

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]