rep could not find interpreter.jl

Hello everyone,

Today I tried updating from sawfish 1.3.3 (the stabil version in
Gentoo-Portage) to sawfish
1.5. So I had to at first install librep 0.90.0 by using following command:

$ configure --prefix /usr && make && make install

Everything built OK but when I started to run 'rep', then I got folloing
error message:

error--> (file-error "No such file or directory" "rep/lang/interpreter")

But the file exists already in the path:

I then tried reverting librep to 0.17 by using the ebuild in Gentoo-Portage.

Again, the rep can not find the file in

After searching for a long time in internet, I found a temporal solution:
set the enviroment
variable 'REP_LOAD_PATH=/usr/share/rep/0.17/lisp' and the rep can now find
the files, but now I
can not compile sawfish anymore, because the makefiles of sawfish using also
this enviroment

I have really no idea, why the rep can not find the files, which were
installed by himself.

Could anybody help?

View this message in context:
Sent from the Gnome - Sawfish mailing list archive at

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]