Re: installation rant (ignore if in bad mood)

On 07/12/09 10:53, Daniel Fetchinson wrote:
<rant on>

Folks, this will be another rant about general user experience.

I consider myself computer literate so compiling from source is never
a problem as long as ./configure; make; make install works. If not, I
consider the software crappy. I tried installing the latest sawfish
bundle, in this order:

librep 0.90.3
rep-gtk 0.90.0
sawfish 1.5.3

First I wanted to install to a custom location using --prefix but that
didn't work, see the other recent thread I started. So I thought,
okay, let's not give sawfish developers a hard time, let's just
install to the default locations. So I did

make install

on librep. All good. Then to rep-gtk: ./configure fails with

checking for LIBREP... no
configure: error: can not locate librep

What?? Even if everything is installed to the default location
configure can't find it. Why?

So what do you get for
    pkg-config --libs librep ?
I get "-lrep -lcrypt -lgmp -lm"

It's a while since I built the sawfish suite, but at time it worked fine on F11 using rpmbuild. I _may_ have needed to add a tweak for x86_64, I'd have to look at the log files of the build. F12 with the current versions will be done "RSN".

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]