Re: [PATCH] exit function



We've been terrible for suspend; after the function call, it comes
back. So it should be

(define (exit action)
  (case action
    ((reboot)    
     (call-hook 'before-exit-hook)
     (map-windows delete-window)
     (system (format nil "%s &" reboot-command)))
    ((halt)      
     (call-hook 'before-exit-hook)
     (map-windows delete-window)
     (system (format nil "%s &" halt-command)))
    ((suspend)   (system (format nil "%s &" suspend-command)))
    ((hibernate) (system (format nil "%s &" hibernate-command)))))

So, the correct name may be "poweroff", both for module and the
function.

>> On Sat, 28 Nov 2009 14:52:26 +0100, Christopher Roy Bratusek wrote:
>> >> Sorry, I wanted to say (defgroup exit "Exit Sawfish" :group misc).
>> > 
>> > Nope. It uses "External Applications" from
>> > sawfish.wm.commands.launcher
>> 
>> Commands for term and browser are set in "external applications",
>> since there's no other way to name them. But reboot/shutdown/suspend
>> can be called 'exit' (or exit-session) , so it's natural.
> 
> On the other hand this would just be polluting SawfishConfig with just
> another group.

Ok, it's settled, but do you think it's cluttered now, and how?  As
for grouping, I don't think it's bad.

>> >> >> what'll be good? 
>> > [] exit
>> > [] safe-quit
>> > [] exit-session
>> 
>> If quit is to be dropped, then exit-session.

Since suspend & hibernate don't kill sawfish, "poweroff".
Teika (Teika kazura)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]