Re: Sawfish or Xorg input bug

On Mon, Mar 3, 2008 at 11:40 PM, GSR - FR <famrom infernal-iceberg com> wrote:


>  Versions are same than yours, but worked fine with 2.6.24 kernel until
>  last Xorg update. Maybe sawfish triggers something in the radeon
>  driver, or the xorg core or kbd driver (or I had luck the week I had
>  new kernel with "old" X). I know it did not happen with radeon driver
>  6.6.x, xorg 1.3 and kernel .23 or older. The time I used radeon 6.7.x
>  (sorry, speaking from memory) I had some full kbd locks (mouse moved,
>  apps updated, but sshing required to kill the server) so I reverted to
>  6.6.

I tried the less effort downgrade, but with kernel 2.6.18 and 2.6.22 I
had no luck. Sigh, it'll be a pain to test older Xorg versions (i
would be happy to isolate the change who broke things or at least in
which package).  T__T

>  Additionally, official Flash plugin r115 worked smoothly with old
>  radeon driver, but with new I had to revert to r48 version or get 80%
>  usage in the Xorg process, 15% in the browser (and 5% in others) and
>  drop frames with XAA accel arch, or poor window refresh and GTK
>  glitches but nice frame rates with EXA (yep, slowdown changed from the
>  flash anim to the rest of the browser). Now when time pases and DPMS
>  is not triggered, I wonder if some vibration moved the mouse or it is
>  another flacky thing. I am starting to see bugs everywhere. :]

I try to keep flash disabled most of the time, it locks the browser
too frequently, but yes, last time I tried I noticed windows scrolling
slowdowns with EXA. The GTK glitch i used to see with EXA (usually
with menus) seems fixed tho.

Now that you mention it, sometimes I've found the monitor still
powered on when instead it should have been on stand-by...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]